Non sempre Chrome batte Explorer…

Non scrivo nulla da tantissimo tempo, credo dipenda soprattutto dal fatto che non lavoro più in autonomia ma ho trovato il mio posto all’interno di una grande agenzia, questo ha messo fine alla rubrica ICMA.

Oggi però ho un fatto curioso da sottoporre a voi smanettoni.

Ho realizzato un effetto a “tendina” obliqua per una pagina particolare e, per procedere più speditamente, stavo testando l’effetto solo su Internet Explorer. Una volta terminato, avendo ottenuto un risultato soddisfacente su IE ecco la sorpresa: l’effetto funzionava su Internet Explorer 10 ma non sull’ultima versione di Chrome. Roba da non credere!

Ecco qua l’esempio (immagini da lorempixel.com):



Cliccando una volta l’immagine sparisce, cliccando la seconda volta ricompare con un effetto obliquo. Ora, se stai guardando l’esempio qui sopra con Opera, FireFox, Microsoft Internet Explorer 10+, Apple Safari (anche su iOS) o Android Browser il tutto funziona, se usi Chrome no!

Il problema si presenta su Windows e su Mac, al momento vi scrivo da un iMac usando Google Chrome Versione 43.0.2357.81 (64-bit) e l’animazione si blocca a metà:

Il “glitch” su Google Chrome.

Il “glitch” su Google Chrome.

La cosa mi ha fatto sorridere: chi fa il mio mestiere passa molte ore a discutere di quanto sia più semplice scrivere codice per Chrome rispetto a Internet Explorer fino a quando non si trova di fronte a una situazione del genere.

Naturalmente ho dovuto trovare una soluzione ma prima di rivelarla mi piacerebbe che qualcun altro provasse a dire nei commenti cosa avrebbe fatto.

La mia soluzione consta di 16 byte, potevo far meglio?

Potrebbero interessarti anche...

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.